Historia zmian w programie

Historia zmian w programie Ewidencji Materiałowej (C) 2003-2016 FOX Computer Service

Historia zmian w programie

Wersja 4.11 z 02.02.2016

Wersja 4.10 z 27.01.2016

Wersja 4.09 z 13.01.2016

Wersja 4.08 z 11.01.2016

Wersja 4.06 z 06.01.2016

Wersja 4.05 z 29.12.2015

Wersja 4.04 z 23.12.2015

Wersja 4.03 z 20.12.2015

Wersja 4.02 z 16.12.2015

Wersja 4.01 z 14.12.2015

Wersja 4.00 z 12.12.2015

Wersja 3.43 z 31.07.2015

Wersja 3.41 z 05.02.2015

Wersja 3.39 z 07.01.2015

Poprzednie wersje F/Z


Wersja 4.11 z 02.02.2016

Wersja 4.11 z 02.02.2016

Poprawione błędy:

1. Poprawiono zaokrąglanie wartości pozycji na dokumentach magazynowych.


Wersja 4.10 z 27.01.2016

Wersja 4.10 z 27.01.2016

Zmiany:

1. Wprowadzono opcję analizy zaksięgowanych dokumentów z dokumentami znajdującymi się w systemie FK. Analiza opiera się o oznaczenie wewnętrzne dokumentu, które stosowane jest zarówno w systemie FK jak i ewidencji materiałowej.

Analiza dostępna jest z poziomu menu Dokumenty > Analiza oznaczeń wewnętrznych

Po jej wybraniu pojawia się powyższe okno. W pierwszej kolejności należy wskazać arkusz XLS zawierający dane z systemu FK. Układ kolumn arkuszu jest stały:

- Data dokumentu w formacie DD/MM/RR

- Oznaczenie wewnętrzne z FK

- Wartość winien

- Wartość kredyt

Arkusz nie może zawierać innych danych, ani tych danych w innej kolejności.

Po odczytaniu arkusza wypełnianie są pierwsze cztery kolumny.

Kolejnym krokiem jest określenie przedziału dat, dla których ma nastąpić analiza dokumentów w EM. Dane w pliku XLS mogą zawierać pozycje z innych dat.

Następnym krokiem jest uruchomienie analizy.

Analiza przebiega dwuetapowo:

W pierwszym kroku sumowane są wartości dokumentów ocechowanych danym oznaczeniem wewnętrznym, a powstała suma jest porównywana z wartością znajdującą się w systemie FK. Jeżeli wystąpią różnice, to wypełniane jest pole w kolumnie Saldo, a cały wiersz ma czcionkę w kolorze czerwonym.

W drugim kroku sprawdzane są dokumenty w systemie EM z przedziału podanych dat w celu wyłapania dokumentów posiadających oznaczenie wewnętrzne inne niż w pliku XLS. Jeżeli tego typu pozycje wystąpią, to są one dopisywane na końcu listy na żółtym tle.

W kolumnie uwagi podawane są numery dokumentów posiadających dane oznaczenie wewnętrzne. Dokumentów powiązanych z danym oznaczeniem może być wiele i mogą znajdować się w różnych magazynach, jak również mogą to być dokumenty przychodowe i rozchodowe.

Wynik analizy można zapiać do pliku XLS poprzez wybranie klawisza Eksport XLS

Poprawione błędy:

1. Poprawiono księgowanie inwentaryzacji


Wersja 4.09 z 13.01.2016

Wersja 4.09 z 13.01.2016

Zmiany:

1. Na formularzu inwentaryzacji zmieniono sposób odświeżania listy pozycji po wykonaniu czynności edycyjnych (dopisywanie, zmiana, kasowanie). Ze względu na dużą ilość pozycji objętych inwentaryzacją, dotychczasowe odświeżanie tej listy zajmowało zauważalny czas. Obecnie ten czas powinien być pomijalny.

Poprawione błędy:

1. Na formularzu inwentaryzacji poprawiono dopisywanie nowych pozycji. Podczas dopisywania pozycja poprzedzająca dopisywaną była zerowana.


Wersja 4.08 z 11.01.2016

Wersja 4.08 z 11.01.2016

Zmiany:

1. Na formularzu kalkulacji materiału do oferty/zlecenia dodano opis wybranej pozycji materiałowej (dotychczas był tylko kod).

2. Na formularzu kalkulacji materiału do oferty/zlecenia zmieniono sposób wypełniania jednostki miary. Jeżeli wybrany materiał ma dwie jednostki to dotychczas wybierana była pierwsza. Obecnie jednostki są analizowane i jako pierwsza wybierana jest jednostka inna niż "kg".

3. Wprowadzono możliwość edytowania dokumentów magazynowych na nowy rok, przy nie zamkniętym jeszcze roku ubiegłym, przy czym nie można ich księgować przed zamknięciem dotychczasowego roku. Ich księgowanie będzie dostępne po zamknięciu roku. Edycja jest dostępna jedynie, gdy grudzień jest miesiącem magazynu w starym roku.

Aby dopisywać takie dokumenty należy:

- wybrać jako aktywny nowy rok (np 2016),

- wywołać listę z dokumentami

- wskazać miesiąc 01 (F9)

- dopisać dokument zwracając uwagę na prawidłowość dat.

Poprawione błędy:

1. Poprawiono działanie wyszukiwania na listach. W przypadku, gdy wyszukiwana fraza nie występowała na liście i lista nie zawierała już żadnych pozycji, aktywną kolumną stawała się pierwsza kolumna, mimo że wyszukiwanie mogło być uruchomione w kontekście innej kolumny. Kolejne wyszukiwanie musiało być poprzedzone ponownym wskazaniem kolumny.

2. Na formularzu kalkulacji materiału do oferty/zlecenia poprawiono wybór materiału. Nie działało wyszukiwanie blankietowe, co mogło wprowadzać w błąd. Obecnie wyszukiwanie działa w identyczny sposób jak w innych miejscach programu.

3. Poprawiono wyszukiwanie zleceń na przełomie starego i nowego roku (domyślnie filtrowanie zleceń dotyczyło roku wynikającego z danych magazynowych).


Wersja 4.06 z 06.01.2016

Wersja 4.06 z 06.01.2016

Zmiany:

1. Dodano możliwość wprowadzania oznaczenia wewnętrznego w dokumentach PR+ i PR-, przy czym nie jest ono obowiązkowe.

Poprawione błędy:

1. Poprawiono edycję pozycji inwentaryzacji. Dla pozycji ręcznie dopisywanych nie działał wybór materiału z list (klawisze list F2 i F3 nie były aktywne). Ponadto dla pozycji pobranych automatycznie była możliwość zmiany materiału.

2. Poprawiono generowanie list inwentaryzacji w zakresie sortowania w/g kodu materiału (pozycje nie były sortowane).


Wersja 4.05 z 29.12.2015

Wersja 4.05 z 29.12.2015

Zmiany:

1. W edytorze pozycji dokumentu magazynowego dodano przycisk pozwalający na wywołanie kalkulatora jednostki miary dla przyjmowanej lub wydawanej ilości danego materiału.

Przycisk jest aktywny jeśli dla danej kartoteki zdefiniowana jest jednostka przeliczeniowa inna niż jednostka kartotekowa. Kalkulator można wywołać również przez naciśnięcie klawisza F5 będąc na polu Ilość:

Przykład 1

Przykład 2

Na górze formularza znajduje się informacja o współczynniku przeliczenia pomiędzy jednostką kartotekową i przeliczeniową.

Ponadto można określić sposób przeliczania danych:

- Zachowaj wartość - wybranie tej opcji zachowuje wartość pozycji, ustawienie domyślne dla dokumentów przychodowych. Ilość i cena są tak dobierane, aby wartość pozycji przed i po przeliczeniu była taka sama. Oznacza to, że zmianie może ulegać ilość materiału. Na powyższym przykładzie 1 widać, że ilość materiału po przeliczeniu jednostki jest inna niż wynikałoby to ze zwykłego przemnożenia ilości przeliczanej i współczynnika (10 m2 * 16.0000 = 160.0000). Jest to konsekwencją zaokrągleń.

- Zachowaj ilość - wybranie tej opcji zachowuje ilość pozycji, ustawienie domyślne dla dokumentów rozchodowych. Wartość i cena są tak dobierane, aby ilość pozycji przed i po przeliczeniu była taka sama. Oznacza to również, że zmianie może ulegać wartość materiału. Na powyższym przykładzie 2 widać, że wartość materiału po przeliczeniu jednostki jest inna niż przed. Jest to konsekwencją zaokrągleń.

Dla dokumentów przychodowych można określić ilość i cenę w jednostce przeliczeniowej.

Dla dokumentów rozchodowych można określić jedynie ilość w jednostce przeliczeniowej, gdyż cena wynika ze stanu magazynowego.


Wersja 4.04 z 23.12.2015

Wersja 4.04 z 23.12.2015

Zmiany:

1. W edytorze pozycji dokumentu magazynowego dodano przycisk z literą "i" dający możliwość bezpośredniego przeglądania kartoteki materiałowej.

2. W edytorze inwentaryzacji dodano zabezpieczenie przed zmianą ceny, w przypadku gdy edytowana pozycja odnosi do istniejącego stanu.

3. Dla dokumentów RW utworzonych na podstawie odczytu danych z kolektora danych, wprowadzono wypełnianie kolumny SM_ID. Pozycje, dla których nie udało się ustalić stanu mają w tej kolumnie wartość "0" (zero).

Poprawione błędy:

1. Poprawiono globalny błąd związany z kasowaniem dokumentów (obiektów) zawierających dużą ilość pozycji.

2. Poprawiono błąd związany z generowaniem dokumentów RW na podstawie danych odczytanych z kolektora danych.


Wersja 4.03 z 20.12.2015

Wersja 4.03 z 20.12.2015

Zmiany:

1. Zmieniono sposób wstępnego filtrowania danych wyświetlanych na listach. Dotychczas, chcąc uzyskać np kontrahenta, którego kod zaczynał się na literę "B", w polu z kodem kontrahenta trzeba było wpisać B*. Obecnie wystarczy wpisać samo B, program domyślnie zastosuje gwiazdkę do wyszukiwania. W dalszym ciągu można wprowadzić bardziej złożone wyszukiwanie np. *ABC*XYZ*, dzięki czemu uzyskamy listę wszystkich kodów, w których występują litery ABC oraz XYZ, przy czym przed ABC, pomiędzy ABC i XYZ oraz za XYZ mogą wystąpić dowolne ciągi znaków. Gwiazdka oznacza dowolny ciąg znaków. W przypadku wpisania gwiazdek, program automatycznie nie dodaje gwiazdki na końcu wprowadzonej frazy.

Jeżeli zostanie użyte tego typu filtrowanie, to w ramach otrzymanych wyników nie trzeba już powtarzać wcześniej wpisanej frazy. W szybkim wyszukiwaniu można użyć dalszych znaków wyszukiwanej pozycji. Dla przykładu wprowadzając kod pozycji materiałowej wpisujemy KOL. W rezultacie ukaże się lista wszystkich materiałów, których kod zaczyna się od KOL. Dla przykładu mogą być to kolana. Jeżeli szukamy danego wymiaru, to wystarczy już podać sam wymiar, a lista zostanie zawężona tylko do pozycji posiadających ten wymiar.

2. Zmieniono mechanizm obsługi plików pomocy i instrukcji do programu z formatu HLP na format CHM. Format HLP przestał być obsługiwany w systemach Windows 10, natomiast dla systemów Windows 7, 8, 8.1 wymagane było zainstalowanie dedykowanej do tego celu aktualizacji.

3. W miejscach wyboru kontrahenta, materiału i zlecenia, jeżeli znany jest kod kontrahenta, materiału lub zlecenia, można go użyć bez konieczności wywoływania listy.

Poprawione błędy:

1. Podczas dopisywania pozycji materiałowej do dokumentu magazynowego poprzez podanie pełnego kodu materiału, nie były pobierane informacje o jego jednostce miary oraz stawce VAT. Ponadto w tym trybie nie pojawiała się lista stanów magazynowych w przypadku dokumentów rozchodowych.

2. Jeżeli na liście stosowano wyszukiwanie danych, to naciśnięcie klawisza Enter powodowało zamykanie okna wyszukiwania i anulowanie wyników wyszukiwania. Obecnie naciśnięcie klawisza Enter wywołuje podgląd danej pozycji lub jej wybór do formularza, z którego lista została wywołana.

3. Jeżeli na liście stosowano wyszukiwanie danych i kliknięto na inną kolumnę niż aktualnie przeszukiwana, to nie zamykało to okna przeszukiwania, mimo, że wybór innej kolumny zmieniał kontekst wyszukiwania. Prowadziło to do dezorientacji. Obecnie, jeżeli aktywne jest okno wyszukiwania i nastąpi kliknięcie na nagłówek kolumny, to okno wyszukiwania zostanie zamknięte, dając możliwość wprowadzenie nowego szukania dla wskazanej kolumny. W tych okolicznościach nie następuje sortowanie wskazanej kolumny, które jest domyślną czynnością w momencie kliknięcia myszą na nagłówek kolumny

Proszę zapoznać się ze zmianami opisanymi dla wersji 4.00 w zakresie obsługi list


Wersja 4.02 z 16.12.2015

Wersja 4.02 z 16.12.2015

Zmiany:

1. Wprowadzono dodatkowe kontrole podczas importu danych ze starego systemu


Wersja 4.01 z 14.12.2015

Wersja 4.01 z 14.12.2015

Zmiany:

1. Zmieniono zakres wymuszania filtrów podczas edycji dokumentów magazynowych.


Wersja 4.00 z 13.12.2015

Wersja 4.00 z 13.12.2015

Zmiany:

Główną zmianą wprowadzoną w wersji 4.xx programu jest przejście z bazy danych Pervasive na bazę danych PostgreSQL. Oznaczało to całkowitą wewnętrzną przebudowę programu, zmianę w podejściu do gromadzenia i przetwarzania danych oraz szereg korzyści dla użytkowników:

1. Brak limitów w dostępie do danych ze strony bazy danych i programu. Zarówno baza danych PostgreSQL jak i oprogramowanie nie mają żadnych limitów co do ilości jednocześnie pracujących osób, zatem dodanie nowych stanowisk odbywa się bezkosztowo. W dalszym ciągu istnieje ograniczenie jednoczesnych połączeń do zasobu w systemie Windows, które dla wersji Professional wynosi 10. Gdyby ta ilość była zbyt mała, to można przejść na wersje serwerowe systemu Windows lub wykorzystać Linuksa (na którym PostgreSQL również z powodzeniem działa)

2. Zabezpieczenie danych przed przypadkowym uszkodzeniem, gdyż pliki bazy danych nie są widoczne dla użytkowników. Są one przechowywane na serwerze w katalogu, który nie jest udostępniany, co zabezpiecza go przed skasowaniem lub uszkodzeniem w wyniku działania różnego rodzaju wirusów. Komunikacja z bazą odbywa się tylko poprzez protokół sieciowy TCP/IP, nie jest wymagany dostęp plikowy.

3. Zmiana silnika bazy danych wprowadziła pilnowanie integralności danych na poziomie bazy danych, a nie na poziomie aplikacji. Dotyczy to powiązań pomiędzy poszczególnymi danymi, np pozycje dokumentów i ich nagłówki. W dotychczasowym rozwiązaniu aplikacja pilnowała powiązań pomiędzy pozycjami dokumentów a ich nagłówkami. Jednak w przypadku ewentualnego uszkodzenia któregoś z plików przechowującego te dane, powiązania te ulegały zerwaniu, o czym aplikacja już nie wiedziała, gdyż stało się to poza jej obszarem działania. W obecnym rozwiązaniu baza na bieżąco sprawdza swoją integralność.

4. Zmiana silnika bazy pozwoliła również na wprowadzenie możliwości przechowywania informacji w formie elektronicznej dla np. zleceń czy pozycji materiałowych (można np. podpiąć pod pozycję materiałową kartę katalogową producenta).

5. Zmienione zostały przeglądarki-listy danych w zakresie wyszukiwania danych i ich sortowania w poszczególnych kolumnach. Obecnie można sortować dane w każdej kolumnie listy, jak również możliwe jest wyszukiwanie danych zarówno w aktywnej kolumnie jak i we wszystkich kolumnach.

6. Zmianie uległ poziom obsługi danych, z poziomu rocznego na wieloletni. Oznacza to, że wszystkie analizy danych mogą obejmować dowolny okres z przeszłości. Np można uzyskać kompletne informacje o obrotach dla zlecenia, które realizowane jest na przełomie lat. To samo dotyczy historii obrotów na kartotekach materiałowych itp.

7. Wprowadzono nową analizę sprawdzającą logiczną spójność danych kartotek materiałowych z ich stanami i dokumentami obrotowymi.

8. Sam program od strony obsługi praktycznie nie uległ zmianie, poza dodatkowymi możliwościami wyszukiwania danych na listach oraz nieco innym podejściem do określenia jakie dane mają być wyszukiwane.

Poniżej opis funkcjonalności nowych listy danych:

Listy są podstawowym elementem służącym do przeglądania i edycji danych zapisanych w programie. Z niewielkimi wyjątkami obsługa list jest identyczna w każdej części programu.

Każdą listę można skalować poprzez chwycenie myszką jej dolnego prawego narożnika. W przypadku zbyt dużego pomniejszenia listy, program sam ustawi minimalną wielkość okna listy. Ustawiona wielkość listy oraz jej położenie na ekranie są pamiętane przez program.

Na każdej liście pierwsza kolumna oznaczona jest literą "S" i oznacza stan danego rekordu (wiersza) na liście. Zapisy historyczne oznaczone są poprzez literę "H" oraz brązowym kolorem tła. W przypadku błędów wiersz oznaczony jest kolorem czerwonym lub/i znakiem "!" w kolumnie "S".

Z prawej strony listy znajduje się suwak pozwalający na szybkie poruszanie się po całej liście oraz informujący w jakim miejscu listy się znajdujemy. Listę można także przewijać stosując rolkę w myszce oraz przy użyciu klawiatury:

- strzałka w górę - wiersz do góry

- strzałka w dół - wiersz w dół

- strzałka w lewo - poprzednia kolumna (przeglądanie na boki)

- strzałka w prawo - następna kolumna (przeglądanie na boki)

- Ctrl+strzałka w lewo - kilka kolumn w lewo (przeglądanie na boki)

- Ctrl+strzałka w prawo - kilka kolumn w prawo (przeglądanie na boki)

- PgUp - pierwszy wiersz listy w ramach okna

- PgDn - ostatni wiersz listy w ramach okna

- Ctrl+PgUp - pierwszy wiersz listy

- Ctrl+PgDn - ostatni wiersz listy

- Home - pierwsza kolumna w wierszu

- End - ostatnia kolumna w wierszu

W przypadku, gdy szerokość listy przekracza szerokość okna, w którym lista jest przeglądana pojawia się poziomy pasek przewijania, przy użyciu którego można przeglądać zasłonięte kolumny.

Aktywny wiersz podświetlony jest kolorem żółtym. W ramach wiersza kolorem jasno-żółtym wyróżniona jest aktywna komórka (kolumna). Dodatkowo nagłówek aktywnej kolumny jest oznaczony również jasno-pomarańczowym kolorem.

W ramach listy dostępne jest szybkie szukanie informacji. Wciśnięcie dowolnego klawisza alfanumerycznego (litera lub cyfra) na klawiaturze powoduje pojawienie się okienka wyszukiwania, w które wpisywać można szukaną frazę. W ślad za wprowadzanymi znakami następuje filtrowanie listy oraz podświetlanie wskazanej frazy. Nazwa aktualnie przeszukiwanej kolumny jest wyróżniona kolorem niebieskim i powiększoną czcionką.

Szerokość kolumn można zmieniać. Najechanie myszką na linię graniczną kolumny powoduje zmianę wyglądu kursora, a po wciśnięciu i przytrzymaniu lewego przycisku możliwa jest zmiana szerokości kolumny.

Dane wyświetlane na liście można sortować w/g danej kolumny, poprzez kliknięcie w nazwę kolumny. Sortowanie może być rosnące lub malejące.

Na samym dole okna listy znajduje się pasek statusu. Pokazuje on ilość wierszy na liście, aktualny wiersz, Ilość znalezionych rekordów spełniających warunek wyszukiwania.

Dodatkowo znajdują się na nim cztery przyciski pozwalające na zmianę sposobu przeszukiwania listy:

- Ukrywaj - decyduje czy rekordy nie spełniające warunku wyszukiwania mają być ukryte czy też nie,

- Typ: *fraza* - określa typ wyszukiwania. Opis *fraza* oznacza, że warunek wyszukiwania jest spełniony, gdy w środku tekstu znajduje się szukany ciąg znaków. Opis fraza* oznacza, że warunek wyszukiwania jest spełniony, gdy w szukany tekst znajduje się na początku tekstu.

- Akt.kolumna - określa, czy wyszukiwanie ma odbywać się tylko w ramach aktywnej kolumny wskazanej przez położenie aktywnej komórki, czy też we wszystkich kolumnach.

- Wiersze - określa sposób poruszania się klawiszami Następny/Poprzedni po wyniku wyszukiwania (gdy nie jest włączana opcja Akt.kolumna). Dla opcji "Wiersze" naciskanie tych klawiszy powoduje przechodzenie do następnego/poprzedniego wyniku wierszami, po dojściu do ostatniego wiersza pierwszej kolumny, pozycjonowanie przenoszone jest na kolejną kolumnę itd. Dla opcji "Kolumny" pozycjonowanie dobywa się wpierw w ramach kolumn danego wiersza, a po osiągnięciu ostatniej kolumny pozycjonowanie przechodzi do kolejnego wiersza itd.

Nad paskiem statusu znajdują się klawisze opisujące akcje dostępne dla danej listy. Dwa pierwsze klawisze na liście wyróżnione są innym (zielonkawym) kolorem. Wybranie klawisza "Anuluj" jest równoznaczne z zamknięciem listy poprzez ikonę krzyżyka w górnym prawym rogu okna listy. Natomiast pierwszy klawisz opisuje akcję wykonaną na liście w wyniku dwukrotnego kliknięcia myszą na wierszu listy. Przeważnie jest to wywołanie opcji "Pokaż" lub "Wybierz". Z reguły poprzez opcję "Wybierz" następuje przeniesienie informacji zawartej w podświetlonym wierszu listy do formularza, z którego lista została wywołana. Pozostałe klawisze opisują inne dostępne akcje, i tak:

- F3 Dopisz - służy do uruchomienie procedury dopisywania danych do listy

- F5 Zmień - służy do zmiany danych zapisanych w podświetlonej pozycji listy

- F6 Pokaz - służy do przeglądania danych zapisanych w podświetlonej pozycji listy (bez możliwości ich edycji)

- F7 Szukaj - wywołuje formularz, na którym można wpisać szukaną frazę

- F8 Usuń - służy do skasowania (lub przeniesienia do historii) podświetlonej pozycji

- F9 Filtr - pozwala określić wyrażenie filtrujące listę

- F10 Drukuj - pozwala na wydruk listy oraz jej zapisanie w wybranym formacie.

Dostępne akcje można również wywoływać poprzez klawisze funkcyjne (F2-F12) lub poprzez menu kontekstowe listy dostępne pod prawym przyciskiem myszy.

W menu kontekstowym znajdują się opcje pozwalające na eksportowanie danych listy do różnych formatów (txt, csv, xls, xml, html)

Na niektórych listach możliwe jest zaznaczanie pozycji, na których można wykonać pewne operacje w zależności od szczegółowych akcji związanych z daną listą. Jeżeli dostępne jest zaznaczanie, to kolumna "S" jest szersza i zawiera napis "Stan". Zaznaczanie pozycji odbywa się klawiszem "spacji", a zaznaczone pozycje w kolumnie "Stan" oznaczone są znakiem "v". Istnieje możliwość zaznaczenia do 500 pozycji. Ilość zaznaczonych pozycji podawana jest w tytule okna listy. Pozycje zaznaczać można w dowolnej kolejności oraz w dowolnych miejscach listy.

W przypadku stosowania filtra wyszukiwania należy liczyć się ze spowolnieniem wyświetlania danych na liście. Wynika ono z tego, że program musi przeanalizować każdy rekord, a jedynie niektóre z nich spełniają warunek filtra. Aktywność filtra sygnalizowana jest przez opis w nazwie okna z listą (Filtr aktywny / nieaktywny).

Jeżeli w opisie klawisza występuje znak "^" np.: "F8^Usuń", to naciśnięcie tego klawisza przy wciśniętym klawiszu CTRL na klawiaturze spowoduje wywołanie innej akcji, niż opisana klawiszem. Dla przykładu naciśnięcie klawisza "F8^Usun" powoduje przeniesienie danego rekordu do historii (bez kasowania z bazy). Natomiast naciśnięcie go wraz z klawiszem CTRL powoduje trwałe skasowanie rekordu z bazy. Obie te operacje poprzedzone są pytaniem o chęć kasowania.

Zmiany w obsłudze programu

Wizualnie program jest prawie identyczny do poprzedniej wersji. Są jednak pewne zmiany od strony wprowadzania danych. Wynika to z innego sposobu odwołań do bazy SQL.

Baza SQL działa na zasadzie pytanie - odpowiedź. Oznacza to tym samym, że im bardziej ogólne pytanie zostanie zadane, tym więcej informacji się uzyska i niekoniecznie będą to dane potrzebne. W praktyce sprowadza się to do tego, że jeśli chcemy wybrać kontrahenta lub pozycję materiałową, to wpierw trzeba określić wstępny filtr na kontrahenta, materiał lub zlecenie.

Jest to sytuacja odwrotna od dotychczasowej, w której wpierw wywoływano listę, a dopiero potem na niej szukano danych. Jeżeli teraz wywołamy listę bez podania wstępnego filtrowania, to otrzymamy wszystkie pozycje z danej tabeli, co może spowalniać wprowadzanie danych.

Dlatego też uwolniona została edycja pól typu Kod kontrahenta, materiału i zlecenia, aby przed wywołaniem listy można było określić czego się szuka.

Jeżeli wiadomo, że np kod kontrahenta zaczyna się od litery "B", to w polu kontrahenta wpisujemy literę "B*" (B+gwiazdka) i w rezultacie dostajemy wszystkich, których kod zaczyna się od litery B. Można również wpisać *ABC*, wtedy lista pokaże wszystkie firmy, które zawierają w sowim kodzie ABC.

To samo dotyczy towarów i zleceń.

Jeżeli już dostaniemy daną listę wyników, to w jej ramach dostępne jest wyszukiwanie poprzez wpisywanie fragmentu tekstu, przy czym to wyszukiwanie domyślnie realizowane jest w aktywnej kolumnie. Można również szukać przez F7 szukaj jak było to dotychczas.

Jeżeli na liście jest klawisz F9 Filtr, to można zmienić warunki filtrowania, czyli np zmienić szukanego kontrahenta z B na C.

W przypadku wywołania list kontrahentów, materiałów lub zleceń i nie określeniu wstępnego filtrowania, pojawia się dodatkowy formularz pozwalający na określenie parametrów filtra w celu zawężenia ilości otrzymanych danych, przy czym możliwe jest jego zatwierdzenie bez podania żadnych parametrów filtrujących, Wtedy wykaz będzie obejmował wszystkie rekordy w danej tabeli.


Wersja 3.43 z 31.07.2015

Wersja 3.43 z 31.07.2015

Zmiany:

1. Do wydruku "Analiza realizacji zleceń" dodano wiersz z danymi kontrahenta składającego zamówienie.

2. W formularzach dotyczących analizy obrotów materiałów rozszerzono listę analizowanych miesięcy o miesiąc 00 odpowiadający Bilansowi Otwarcia w danym roku.

3. Wprowadzono możliwość dodawania załączników do zamówień. Celem tej modyfikacji jest umożliwienie przechowywania korespondencji związanej z realizacją zamówienia, np pamiętanie otrzymanych ofert.

Na formularzu zamówienia dodano klawisz Załączniki. Jego kliknięcie wywołuje listę załączników związanych z danym zamówieniem. Standardowo w ramach listy dostępne są klawisze edycyjne F3 Dopisz ... F8 Usuń. Wprowadzenie załącznika wymaga podania Daty, Opisu załącznika oraz wskazania pliku z treścią załącznika.

Przed dodaniem załącznika można określić przeszukiwany katalog (Moje Dokumenty, Pulpit, Dysk C, Ostatnio wybrany). W zależności od tego wyboru zachowuje się kliknięcie przycisku "Dodaj plik". Obecnie jako załączniki mogą być dodawane pliki (PDF, JPG, BMP, DOC, DOCX, XLS, XLSX, TXT).

W drugiej kolumnie listy załączników znajduje się pole wyboru. Jego zaznaczenie ma wpływ na działanie akcji "F8 Usuń". Jeżeli będą zaznaczone jakieś załączniki, to usuwanie będzie dotyczyło zaznaczonych załączników. W przypadku, gdy żaden załącznik nie będzie zaznaczony - kasowanie będzie dotyczyło aktualnie podświetlonego załącznika.

Kliknięcie na komórkę listy z nazwą pliku powoduje uruchomienie podglądu tego pliku przy użyciu standardowych narzędzi systemu operacyjnego powiązanych z typem danego pliku, np dla plików PDF może być to Acrobat Reader, dla plików DOC, XLS - Pakiet Office.

Poprawione błędy:

1. Poprawiono błąd "Floating operation" podczas księgowania dokumentu.

2. Poprzez dodanie miesiąca 00 w formularzu definicji parametrów analizy obrotów, poprawiono błąd polegający na nie uwzględnianiu dokumentów Bilansu Otwarcia w analizach obrotów materiałowych. Powodowało to zaniżanie wartości przychodów, a tym samym wartości magazynów i w konsekwencji rozbieżność pomiędzy zestawieniami stanów magazynowych i obrotów magazynowych.

Powyższa sytuacja nie ma zastosowania dla "Analizy obrotów dla zleceń", gdyż obroty te nie występują w dokumentach BO. Tego typu analiza ma sens dla miesięcy 01-12 danego roku i dlatego dla tych analiz miesiąc startowy powinien znajdować się w zakresie 01-12, tak jak to było dotychczas.


Wersja 3.41 z 05.02.2015

Wersja 3.41 z 05.02.2015

Zmiany:

1. W edytorze inwentaryzacji wprowadzono dodatkowe zabezpieczenia dla edycji pozycji inwentaryzacji. Dodano również możliwość skalowania okna inwentaryzacji.


Wersja 3.39 z 07.01.2015

Wersja 3.39 z 07.01.2015

Zmiany:

1. Lista materiałów wyświetlanych podczas wprowadzania dokumentów rozchodowych jest obecnie filtrowana w celu pominięcia stanów zerowych.

2. Umożliwiono edycję daty dokumentu, dla dokumentów już zaksięgowanych.

3. Zmodyfikowano formularz inwentaryzacji oraz dodano w nim możliwość wyszukiwania materiałów (naciśnięcie alfanumerycznego klawisza uaktywnia okno wyszukiwania). Zmodyfikowano również wydruki inwentaryzacyjne.

Poprawione błędy:

1. Poprawiono błąd "Floating operation" podczas księgowania dokumentu


Poprzednie wersje F/Z

Poprzednie wersje F/Z

Wersja 3.44 z 29.09.2015

Poprawione błędy:

1. Poprawiono problem z księgowaniem składników potrzebnych do kompletacji produktu złożonego. W przypadku małych ilości występował problem z zaokrąglaniem ostatniej cyfry co traktowane mogło być jako niedobór składnika.

Wersja 3.43 z 31.07.2015

Zmiany:

1. W formularzach dotyczących analizy obrotów materiałów rozszerzono listę analizowanych miesięcy o miesiąc 00 odpowiadający Bilansowi Otwarcia w danym roku.

2. Wprowadzono możliwość dodawania załączników do zamówień. Celem tej modyfikacji jest umożliwienie przechowywania korespondencji związanej z realizacją zamówienia, np pamiętanie otrzymanych ofert.

Na formularzu zamówienia dodano klawisz Załączniki. Jego kliknięcie wywołuje listę załączników związanych z danym zamówieniem. Standardowo w ramach listy dostępne są klawisze edycyjne F3 Dopisz ... F8 Usuń. Wprowadzenie załącznika wymaga podania Daty, Opisu załącznika oraz wskazania pliku z treścią załącznika.

Przed dodaniem załącznika można określić przeszukiwany katalog (Moje Dokumenty, Pulpit, Dysk C, Ostatnio wybrany). W zależności od tego wyboru zachowuje się kliknięcie przycisku "Dodaj plik". Obecnie jako załączniki mogą być dodawane pliki (PDF, JPG, BMP, DOC, DOCX, XLS, XLSX, TXT).

W drugiej kolumnie listy załączników znajduje się pole wyboru. Jego zaznaczenie ma wpływ na działanie akcji "F8 Usuń". Jeżeli będą zaznaczone jakieś załączniki, to usuwanie będzie dotyczyło zaznaczonych załączników. W przypadku, gdy żaden załącznik nie będzie zaznaczony - kasowanie będzie dotyczyło aktualnie podświetlonego załącznika.

Kliknięcie na komórkę listy z nazwą pliku powoduje uruchomienie podglądu tego pliku przy użyciu standardowych narzędzi systemu operacyjnego powiązanych z typem danego pliku, np dla plików PDF może być to Acrobat Reader, dla plików DOC, XLS - Pakiet Office.

Poprawione błędy:

1. Poprawiono błąd "Floating operation" podczas księgowania dokumentu.

2. Poprzez dodanie miesiąca 00 w formularzu definicji parametrów analizy obrotów, poprawiono błąd polegający na nie uwzględnianiu dokumentów Bilansu Otwarcia w analizach obrotów materiałowych. Powodowało to zaniżanie wartości przychodów, a tym samym wartości magazynów i w konsekwencji rozbieżność pomiędzy zestawieniami stanów magazynowych i obrotów magazynowych.

Powyższa sytuacja nie ma zastosowania dla "Analizy obrotów dla zleceń", gdyż obroty te nie występują w dokumentach BO. Tego typu analiza ma sens dla miesięcy 01-12 danego roku i dlatego dla tych analiz miesiąc startowy powinien znajdować się w zakresie 01-12, tak jak to było dotychczas.

Wersja 3.41 z 05.02.2015

Zmiany:

1. W edytorze inwentaryzacji wprowadzono dodatkowe zabezpieczenia dla edycji pozycji inwentaryzacji. Dodano również możliwość skalowania okna inwentaryzacji.

Wersja 3.39 z 07.01.2015

Zmiany:

1. Lista materiałów wyświetlanych podczas wprowadzania dokumentów rozchodowych jest obecnie filtrowana w celu pominięcia stanów zerowych.

2. Umożliwiono edycję daty dokumentu, dla dokumentów już zaksięgowanych.

3. Zmodyfikowano formularz inwentaryzacji oraz dodano w nim możliwość wyszukiwania materiałów (naciśnięcie alfanumerycznego klawisza uaktywnia okno wyszukiwania). Zmodyfikowano również wydruki inwentaryzacyjne.

Poprawione błędy:

1. Poprawiono błąd "Floating operation" podczas księgowania dokumentu

Wersja 3.37 z 16.07.2014

Poprawione błędy:

1. Poprawiono pewne błędy występujące podczas wystawiania dokumentów przychodowych, w sytuacji gdy nie była używana opcja auto-stanów.

Wersja 3.36 z 08.07.2014

Poprawione błędy:

1. Poprawiono obsługę pozycji wieloskładnikowych podczas księgowania dokumentu.

Wersja 3.35 z 04.07.2014

Zmiany:

1. Wprowadzono możliwość kopiowania kodu zlecenia do pozycji dokumentu magazynowego.

Wersja 3.34 z 03.07.2014

Zmiany:

1. Wprowadzono możliwość ręcznego podawania kodu zlecenia, podczas wprowadzania czasu pracy maszyn (podobnie jak przy pracownikach).

2. Dodano w parametrach operatora informację o aktywności czerwonej ramki wkoło aktywnego pola. Jeżeli ma być ona widoczna, to trzeba zaznaczyć tą opcję.

Wersja 3.33 z 30.06.2014

Zmiany:

1. Rozszerzono listę materiałów o kolumnę z informacją o ilości składników danego materiału.

2. Dodano podsumy w analizie pracy pracowników i maszyn.

3. Wprowadzono możliwości wystawiania dokumentów bez wskazania stanu magazynowego dla dokumentów rozchodowych. Dotychczas podczas wystawiania dokumentu, trzeba było określić stan magazynowy, z którego wynika pozycja na dokumencie. W przypadku, gdy ogólna ilość danego towaru wynosiła np 10 szt, z czego 2 szt były w cenie A, 5 szt było w cenie B, a pozostałe 3 szt były w cenie C, to chcąc wystawić dokument na np 9 szt trzeba było wskazywać poszczególne stany, czyli 2 w cenie A, 5 w cenie B i 2 w cenie C tworząc tym samym 3 pozycje na dokumencie.

Obecnie wystarczy podać 9 szt, a podczas księgowania dokumentu program sprawdzi dostępność i rozbije te 9 szt na poszczególne stany magazynowe. Jednocześnie po takim rozbiciu pokazana zostanie nowa, zaktualizowana zawartość dokumentu, w tym ewentualnie skorygowane ceny i wartości.

4. Wprowadzono obsługę pozycji zawierających składniki.

Podczas wystawiania dokumentu, w tym odczytu raportu wagowego, na dokumencie pojawia się pozycja zwierająca składniki np "Mieszanka 1", przy czym nie ma blokady na ilość dostępnego towaru w magazynie (jest tylko komunikat o ewentualnym przekroczeniu stanu). Obsługa takiego towaru odbywa się podczas księgowania dokumentu. W pierwszej kolejności zdejmowane są istniejące stany tej pozycji, natomiast brakująca reszta jest kompletowana w dalszej kolejności i umieszcza na dokumencie w postaci kartotek składowych "Mieszanki". Całość podlega zasadom opisanym w punkcie 3.

5. Wprowadzono odczyt raportów wagowych w miejsce kwitów wagowych.

W przypadku raportów wagowych należy zastosować właściwe nazewnictwo generowanych plików CSV, tak aby sortowanie po nazwie pliku dawało właściwą chronologię, gdyż ma to wpływ na tworzenie dokumentów magazynowych. Zalecam następujący sposób:

2014-06-01_06.csv -> dane od 01 do 06 czerwca 2014

2014-06-07_09.csv -> dane od 07 do 09 czerwca 2014

2014-06-09_12.csv -> dane od 09 do 12 czerwca 2014

Wprowadzone zmiany mają charakter niskopoziomowy dla programu, gdyż dotykają wszystkich mechanizmów, dlatego proszę o szczególne zwracanie uwagi na pracę programu i w razie stwierdzenia nieprawidłowości, bezzwłoczne zgłaszanie problemu wraz z przesłaniem kopii danych.

Wersja 3.32 z 08.06.2014

Zmiany:

1. W kartotece materiałowej dodana została nowa zakładka pozwalająca na określenie składników danego materiału. Ma to zastosowanie w przypadku mieszanek kruszyw lub kompletowania materiału z innych materiałów znajdujących się w magazynie.

W związku z tym zakładany jest nowy plik w katalogu rocznym o nazwie PM_SKL.BTR.

2. Dodana została obsługa czasu pracy maszyn oraz wydruk na zasadach analogicznych jak dla pracowników.

W związku z tym zakładany jest nowy plik w katalogu programu o nazwie MASZ_ZLEC.BTR.

3. Zmieniono formularz dokumentu pod kątem podawania nazwy towarów, zleceń i kontrahenta. Można również określić domyślne zlecenie dla całego dokumentu Ponadto istnieje możliwość przenoszenia zlecenia do pozycji dokumentu. Dodano skalowanie formularza dokumentu.

4. W Systematyce > Parametrach systemu został dodany włącznik, który pozwala na użycie tylko jednego zlecenia w ramach dokumentu magazynowego.

5. W Systematyce > Słowniki własne > został dodany słownik na definicję rodzajów paliw wykorzystywany w maszynach, wykorzystywany podczas wprowadzania kart pracy pojazdów i maszyn.

Wersja 3.31 z 27.05.2014

Zmiany:

1. Wprowadzono komunikację z programem wagowym "Masa". W wyniku ważenia program "Masa" generuje kwit wagowy, który następnie importowany jest do ewidencji tworząc dokumenty magazynowe RW, PW, PZ, WZ w zależności od informacji znajdujących się na kwicie wagowym.

Wersja 3.30 z 25.05.2014

Zmiany:

1. Rozszerzono wydruk rozliczenia czasu pracy o informacje dotyczące kosztów pracy. Dodatkowo dodany został włącznik pozwalający na ujęcie kosztów pracy w kontekście stanowisk pracy w tym stawki za roboczogodzinę dla danego stanowiska.

2. Wprowadzony został mechanizm wyróżniający aktywne pole formularza poprzez ujmowanie go w czerwoną ramkę. Na powyższym formularzu widać, że aktywnym polem jest pole "Od Daty".

Wersja 3.28 z 23.02.2014

Zmiany:

1. Rozszerzono wydruki: Dokument, Analiza obrotu dla zleceń - analitycznie oraz Analiza obrotu w/g rodzaju dokumentów (analityczna) o informacje dotyczące oznaczenia wewnętrznego dokumentu.

2. Dodano kontrolę wymagalności wypełnienia pola na oznaczenie wewnętrzne dokumentu oraz przycisk kalendarza przy dacie dokumentu (kalendarz dostępny jest też poprzez klawisz F2).

Poprawione błędy:

1. Poprawiono wydruk obrotu materiałowego z cenami i bez cen.

Wersja 3.27 z 16.02.2014

Zmiany:

1. Na formularzu dokumentu PZ dodano pole pozwalające na wprowadzenie informacji o oznaczeniu wewnętrznym dokumentu. Ze względu na zmianę przepisów księgowych, data dokumentu PZ nie jest już automatycznie wypełniana - wymaga ręcznego wprowadzenia. Naciśnięcie klawisza F2 na polu daty pokazuje kalendarz, w którym można również wskazać datę.

2. Ze względu na zmianę przepisów księgowych umożliwiono również wprowadzanie i księgowanie dokumentów w innych miesiącach niż aktualny. Wymaga to jednak pełnej komunikacji z działem księgowości w celu uniknięcia rozbieżności.

Wersja 3.26 z 07.01.2014

Zmiany:

1. Wprowadzono obligatoryjność wypełnienia pola "Konto" na kartotece materiałowej.

Wersja 3.25 z 01.01.2014

Poprawione błędy:

1. W wydruku "Analiza obrotów dla zlecenia - syntetycznie" poprawiono analizowanie grupy zleceń.

Wersja 3.24 z 11.11.2013

Zmiany:

1. Dodano do wydruku "Analiza obrotów dla zlecenia - syntetycznie" zestawienie obrotów dla grupy zleceń, które jest również eksportowane do Excel-a.

Wersja 3.23 z 03.11.2013

Zmiany:

1. Wprowadzono obsługę grup kont stanowiących systematykę nadrzędną dla zleceń. Konta przypisane są do kartotek materiałowych i wykorzystywane podczas analizy obrotów dla zleceń w układzie syntetycznym. Konta definiowane są z poziomu menu Systematyka > Słowniki własne > Konta, a następnie wprowadzane do kartotek materiałowych.

2. Utworzony został nowy raport "Analiza obrotów dla zlecenia - syntetycznie" dostępny z poziomu menu wydruków. Dane w raporcie zbierane są w sposób sumaryczny. Po wyjściu z podglądu raportu można dane w nim zawarte zapisać do arkusza Excel-a. Program korzysta ze wzorca arkusza zapisanego w pliku Wzor_ObrZlecSyn.xls, który po wypełnieniu zostaje zapisany w katalogu raportowym użytkownika pod nazwą ObrZlecSyn.xls.

3. Wprowadzono komunikat informujący o błędzie logowania użytkownika w przypadku podania błędnego hasła lub błędnej nazwy użytkownika programu.

Wersja 3.22 z 01.08.2013

Poprawione błędy:

1. Poprawiono błąd związany z kopiowaniem archiwizacji do wskazanego w parametrach systemu katalogu.

Wersja 3.21 z 18.07.2013

Zmiany:

1. Wprowadzono możliwość filtrowania listy zamówień, poprzez akcję "F9 Filtr".

Wprowadzono możliwość filtrowania listy zamówień, poprzez akcję "F9 Filtr". W wyniku jej wybrania pojawia się formularz z możliwością określenia parametrów filtrowania listy zamówień.

2. Rozszerzono wydruk listy zamówień (akcja F10 Drukuj) o podsumowanie, na którym podana jest łączna wartość zamówień w poszczególnych walutach. O zawartości wydruku decydują parametry filtra opisanego w punkcie 1.

3. Uporządkowano moduł podglądu wydruku. Wycofane zostały opcje już niewykorzystywane. Na belce z klawiszami szybkiego dostępu, zostały umieszczone opcje związane z zapisem i eksportem wydruku. Uporządkowane zostały ikony. Zmodyfikowane zostało również otwieranie raportów zapisanych na dysku.

Wersja 3.20 z 08.06.2013

Zmiany:

1. Zmieniono wygląd okna głównego programu. Opcje menu najczęściej używane zostały umieszczone na pasku szybkiego dostępu, znajdującym się pod menu głównym. Wydzielona została ramka na informacje o aktywnym magazynie i okresie obrachunkowym.

2. W menu Systematyka dodano opcję Styl pozwalającą na zmianę wyglądu.

3. Zmianie uległ wygląd list przeglądania danych. Wprowadzone zmiany mają również na celu zwiększenie płynności przeglądania danych na tych listach

4. W menu dotyczącym obsługi czytnika kodów kreskowych, dodano opcję zapis słownika materiałów pozwalająca na jego wczytanie do EXCEL-a. Słownik zawiera kolumnę z kodem kreskowym w systemie 39 stosowanym w czytnikach kodów. Do prawidłowego wyświetlenia tej kolumny należy mieć zainstalowaną czcionkę TTF obsługująca CODE 39.

5. Zmieniono układ opcji w menu wydruków. Obecnie są one wyprowadzone o poziom wyżej, dzięki czemu dostęp do nich jest szybszy.

6. Dodano pozycjonowanie list Kontrahentów i Zleceń w/g kodów użytych na formularzu. Jeżeli na formularzu jest określone zlecenie lub kontrahent, to po wywołaniu listy zleceń lub kontrahentów, lista ustawi się na kontrahencie lub zleceniu użytym na formularzu.

7. Wyjście z programu będące rezultatem naciśnięcia klawisza "ESC" jest poprzedzone komunikatem o chęć zakończenia pracy z programem.

Wersja 3.11 z 04.05.2013

Zmiany:

1. Wprowadzono w zamówieniach możliwość określenia rabatu kwotowego i upustu procentowego dla całego zamówienia. Rabat i upust wyliczane są od kwot netto i brutto wynikających z sumowania poszczególnych pozycji zamówienia. Jeżeli w pozycjach zamówienia są określone indywidualne rabaty lub upusty, to upust lub rabat do całości zamówienia będzie powiększał wartości wynikające z poszczególnych pozycji. Warunkiem określenia rabatu do całości dokumentu jest, aby wszystkie pozycje zamówienia miały taką samą stawkę VAT (jest to podyktowane wyliczeniem kwoty brutto i podatku VAT)

2. W ślad za zmianami z pkt.1 zmienione zostały wydruki zamówień.

Wersja 3.10 z 10.01.2013

Zmiany:

1. Przegląd pozycji zamówień w/g zlecenia maszyny został poprzedzony możliwością zdefiniowania filtra na konkretną maszynę lub zlecenie.

2. Zmodyfikowano wydruk zamówienia w obszarze stopki w kontekście danych do wystawienia faktury, tak aby lepiej wykorzystywać dostępne miejsce na papierze.

3. Wprowadzono mechanizm automatycznego uzupełniania specyfikacji maszyny materiałami wydawanymi z magazynu dla tej maszyny. W momencie księgowania dokumentu RW, w oparciu o kody maszyn znajdujące się przy wydawanych pozycjach materiałowych, następuje sprawdzenie, czy kod danego materiału znajduje się w specyfikacji maszyny. Jeśli nie znajduje się, to zostaje do niej dopisany.

Wersja 3.00 z 07.01.2013

Zmiany:

1. Rozszerzono parametry operatora o konto poczty e-mail.

2. Wprowadzono nowy moduł rejestracji zamówień. Dostępny jest on w poniższym miejscu:

Opcje od 1 do 3 pozwalają na przeglądanie zamówień w/g wybranego parametru.

Opcje od 4 do 8 pozwalają na przeglądanie pozycji zamówień w/g wybranego parametru. W ramach tych list działa wyszukiwanie blankietowe w zakresie kodu i nazwy zamawianego produktu, uruchamiane przez CTRL+F7. Wpisując szukaną frazę w postaci *tekst*, program ustawi listę na pozycję zawierającą w swojej nazwie lub kodzie frazę "tekst".

Opcje A i B pozwalają na przeglądanie kartotek zamawianych towarów w/g wybranego parametru. W ramach tych list również działa wyszukiwanie blankietowe.

Zasada tworzenia zamówień jest identyczna do tworzenia dokumentów magazynowych (PZ, RW). W celu utworzenia nowego dokumentu należy wybrać przycisk "F3 Dopisz". Program wstępnie wypełni pola nagłówka zamówienia. Data dostawy jest większa o 14 dni od daty bieżącej, a płatność domyślnie przyjmuje wartość "14 dni".

Możliwe jest też utworzenie nowego zamówienia na podstawie zamówienia już istniejącego. W tym celu należy wskazać na liście istniejące zamówienie i wybrać CTRL+F3 Dopisz. Nagłówek nowego dokumentu zostanie dostosowany do bieżącej daty i operatora, natomiast pozycje dokumentu i dostawca zostaną bez zmian.

Podczas wystawiania zamówienia, program automatycznie ustala jego numer jako kolejny w stosunku do dotychczas wystawionych zamówień. Podczas pracy w sieci, przy jednoczesnym wystawianiu zamówień przez różnych operatorów, w momencie zapisu do bazy program będzie sprawdzał i aktualizował numer zamówienia, tak aby się on nie pokrył z istniejącym już w bazie. Ewentualna zmiana numeru, jest sygnalizowana komunikatem.

W celu kontynuacji istniejącej numeracji zamówień, pierwsze zamówienie należy wystawić wpisując ręcznie początkowy numer zamówienia.

Wystawione zamówienia można drukować z poziomu listy zamówień przez "F4 Druk zamówienia" lub z poziomu dokumentu zamówienia poprzez "F10 Drukuj". W obu przypadkach pojawi się pytanie o wersję językową wydruku. Dostępne są dwie wersje: polska i angielska.

3. Wraz z tym wydrukiem, do programu został wprowadzony generator raportów FastReport. Poniżej przykład podglądu raportu oraz opis poszczególnych opcji (ikon).

Opis opcji

1 - wydruk na drukarce, z możliwością zdefiniowania parametrów drukowania (standardowy formularz wydruku dokumentu)

2 - wczytanie raportu z dysku, raporty tworzone przez FastReport mają rozszerzenie *.fp3

3 - zapis raportu na dysk w formacie FastReport (*.fp3)

4 - rozwija menu z opcjami eksportu raportu do różnych formatów

5 - uruchamia eksport do PDF-a (szybki dostęp do pozycji w menu opcji 4)

6 - pozwala na wysłanie raportu przez e-mail (szybki dostęp do pozycji w menu opcji 4). W celu wysłania raportu w ten sposób, trzeba znać parametry posiadanego konta pocztowego (użytkownik, hasło, serwery itp) oraz wybrać metodę utworzenia wiadomości

7 - wyszukiwanie tekstu

8,9,A - skalowanie podglądu wydruku

B - przegląd wydruku w trybie pełnoekranowym, powrót do menu następuje poprzez dwukrotne kliknięcie lewym przyciskiem myszy w obszarze podglądu lub poprzez wybranie opcji z menu kontekstowego pod prawym przyciskiem myszy

C - włącza / wyłącza konspekt raportu o ile jest on dostępny

D - włącza / wyłącza miniaturki (kafelki) poszczególnych stron

E - pozwala zmienić definicję domyślnych marginesów w celu przesunięcia wydruku na stronie, nie powoduje ponownego generowania wydruku

F - włącza edytor wydruku strony, pozwala zmodyfikować treść na stronie

G..K - pozwala nawigować po stronach wydruku.

Wersja 2.99b z 14.11.2012

Zmiany:

1. Zmianie uległ formularz podglądu wydruku.

W przypadku, gdy w parametrach operatora włączona jest opcja "Szybkiego podglądu wydruku”, na formularzu podglądu pojawia się przycisk "Edytor" oraz opcja "Zapisz". Wybranie przycisku "Edytor" pozwala na przejście do edytora wydruku po zakończeniu podglądu. Natomiast zaznaczenie opcji "Zapisz" oznacza, że przeglądany wydruk zostanie zapisany na dysku pod nazwą właściwą dla danego rodzaju wydruku.

Poprawione błędy:

1. Na wydruku dokumentu magazynowego i zamówienia, poprawiono obliczanie VAT dla stawek 5% i 3%.

Wersja 2.99a z 22.05.2012

Poprawione błędy:

1. Na wydruku dokumentu magazynowego i zamówienia, poprawiono obliczanie VAT dla stawki 8%

Wersja 2.99 z 16.05.2012

Zmiany:

1. Wprowadzono skalowanie formularza dokumentu magazynowego (np. PZ, RW itd)

2. Wprowadzono obsługę pola danych dotyczących ilości z dokładnością do 4-ch miejsc po przecinku. Dotychczas były 2 miejsca.

Wersja 2.98 z 18.04.2012

Zmiany:

1. W parametrach operatora wprowadzono możliwość ustawienia szybkiego podglądu wydruku oraz określenie domyślnej skali podglądu wydruku.

Włączenie szybkiego podglądu oznacza, że po sporządzeniu wydruku nie będzie pojawiał się edytor wydruku tylko od razu rzeczywisty podgląd. Dotychczas, aby ten właściwy podgląd uzyskać trzeba go było ręczne wywołać z poziomu edytora wydruku, np. poprzez klawisz F4.

Skala podglądu pozwala na zmianę domyślnego skalowania podglądu wydruku, które uzależnia skalę do rozdzielczości monitora.

2. Poprawiono działanie podglądu wydruku w zakresie skalowania i przeglądania stron

Dotychczas po ręcznym zmienieniu skali wydruku, występował problem z przeglądaniem stron przy pomocy klawiszy PgUp i PgDown. Zamiast przeglądu kolejnych stron, zmieniana była skala podglądu.

Dodatkowo wprowadzono możliwość zmiany skali poprzez naciśnięcie klawisza Ctrl i kręcenie kółkiem myszy (podobnie jak w przeglądarkach internetowych, czy pakiecie MS Office)

W przypadku, gdy w parametrach operatora włączona jest opcja "Szybkiego podglądu wydruku”, na formularzu podglądu pojawia się opcja "Powrót do edytora" pozwalająca na przejście do edytora wydruku po zakończeniu podglądu.

3. W edytorze wydruku dodano możliwość zapisu wydruku w formacie TXT

Zapis do formatu TXT jest zapisem stratnym, co oznacza, że utracie ulega formatowanie np tabel. Opcja ta jest przeznaczona głównie do zapisu uzyskanej na wydruku treści w celu jej dalszego przetwarzania, np wczytania do arkusza kalkulacyjnego czy edytora tekstu.

4. W systematyce podzielono słowniki na własne i obce.

W słownikach własnych dodano słownik Państw oraz możliwość eksportu i importu słownika. W wyniku eksportu słownika, w katalogu programu tworzony jest plik EM_Slow.txt. Import słownika następuje poprzez odczytanie danych z tego pliku.

W słownikach obcych znajdują się dane pozyskiwane ze źródeł zewnętrznych, tj średnie kursy walut z NBP oraz kody CN 2012 dla zestawień zakupów zagranicznych przekazywanych do InterStat.

W celu pozyskania kursów walut należy wybrać opcję "Pobierz z NBP" oraz wskazać okres którego pobieranie ma dotyczyć:

W wyniku naciśnięcia przycisku "Pobierz", pobrane zostaną brakujące tabele kursów dla wskazanego okresu. Odczytane kursy walut można przeglądać w/g kryteriów dostępnych w opcji "1. Kursy walut". Wszystkie odczytane tabele kursów zapisywane są również na dysku w katalogu "Kursy".

Opcja "3. Kody CN InterStat" pozwala na przeglądanie kodów CN 2012 zaimportowanych opcją "4. Importuj". Kody CN są wykorzystywane w pozycjach materiałowych oraz w dokumentach transportowych jako słowniki. Import tego słownika następuje z pliku cn_2012.txt

5. Rozszerzono wydruki o analizę obrotów dla zakupów zagranicznych dla InterStat

Wydruk składa się z dwóch części. W pierwszej znajdują się pozycje materiałowe w powiązaniu z dokumentami posortowane w/g kodów materiałów wraz z informacją o walucie oraz jej kursie na dzień zakupu. Drugą część stanowi zestawienie danych z części pierwszej zsumowane w/g kodów CN, jednostki miary i waluty.

6. W pozycjach materiałowych dodano możliwość określenia kodu CN.

Wiele kartotek materiałowych może posiadać ten sam kod CN.

Ponadto zmieniono przycisk "F9. Kartoteka" na "F10. Kartoteka" w ramach procesu ujednolicania wywoływania wydruków poprzez klawisz F10.

7. Rozszerzono dokumenty magazynowe o możliwość ewidencjonowania zakupów zagranicznych.

Zwiększono długość pola "Faktura" z 15 do 30 znaków.

Dodano informację o walucie zakupu. Podczas dopisywania nowego dokumentu, przyjmowana domyślnie jest waluta polska "1-PLN' aby nie utrudniać dotychczasowej pracy.

Na liście pozycji dokumentu dodano kolumnę "Zakup Zagr", w której podawana jest cena netto oraz waluta zakupu.

Na formularzu pozycji dokumentu dodano możliwość wprowadzenia ceny netto zakupu w walucie wskazanej na dokumencie. Dodatkowo program ustala kurs na dzień poprzedzający dzień dokumentu (zgodnie z przepisami księgowymi w tym zakresie). Podawany jest on w nawiasach po oznaczeniu waluty. Podczas opuszczania pola z ceną netto w walucie, program proponuje przeliczenie ceny netto w/g ustalonego kursu, ale możliwe jest wprowadzenie tej kwoty ręcznie z pominięciem przeliczania.

W przypadku, gdy tabela kursów walut nie zawiera kursu na zadany dzień, uruchamiany zostaje proces aktualizacji tabeli kursów opisany w punkcie 4.

8. Rozszerzono dokumenty magazynowe o możliwość korekty pewnych pól, po zaksięgowaniu dokumentu. Korekta może dotyczyć tylko pól nie związanych z zaksięgowanym stanem magazynowym. Do pól tych należą: Faktura, Dostarczył, Uwagi oraz Zlecenie na pozycji dokumentu.

9. Rozszerzono informacje o kontrahencie o pola związane z obsługą dokumentów CMR

Dodano pola na Kraj oraz znaczniki Przewoźnik i Kierowca. Dodatkowo rozszerzono funkcjonalność pola REGON o możliwość zapisywania numeru dowodu osobistego w przypadku ewidencjonowania danych kierowcy. Ze względów porządkowych, wskazane jest jednolite kodowanie firm transportowych oraz kierowców. Można przyjąć zasadę, że kod firmy transportowej będzie zaczynał się od liter "TR_", a kod kierowcy od liter "TK_". Ułatwi to w przyszłości korzystanie ze słownika firm transportowych i kierowców.

Wersja 2.97 z 24.01.2012

Zmiany:

1. Wprowadzono możliwość wygenerowania kartotek pozycji magazynowych

W wyniku wybrania w/w opcji pojawia się formularz pozwalający określić zakres i sposób analizy danych.

Przedmiotem analizy są kartoteki aktualnie posiadające stan magazynowy. Wskazanie wcześniejszego niż obecny rok rozpoczęcia analizy, spowoduje rozszerzenie analizy na lata ubiegłe. Wybranie opcji:

- Wskazany rok dla kartotek ze stanem - uruchomi analizę tylko dla wybranego roku (może być wcześniejszy od aktualnego).

- Wszystkie lata łączenie - uruchomi analizę dla wszystkich lat. Podsumowanie będzie dotyczyło całego okresu analizy.

- Wszystkie lata oddzielnie - uruchomi analizę dla wszystkich lat z tym, że obroty dla każdego roku będą podsumowywane oddzielnie.

W wyniku analizy powstaje plik kartoteki.txt, w którym poszczególne pola oddzielone są znakiem "|", co umożliwia jego zaczytanie do Excel-a.

Wersja F.2.96a z 28.08.2011

Zmiany:

1. Zmodyfikowano import maszyn z pliku CSV. W przypadku braku statusu (aktywny/historyczny) w pliku CSV zachowywany jest bieżący status maszyny.

Wersja F.2.94 z 10.01.2011

Zmiany:

1. Wprowadzono obsługę nowych stawek VAT oraz dodano opcję konwersji dotychczasowych stawek VAT 22 -> 23% oraz 7 -> 8%. Konwersja dotychzasowych stawek uruchamiana jest z poziomu menu "Produkcja > Opcje techniczne > Zmiana stawek VAT". Przed wykonaniem konwersji należy wykonać kopię danych. Konwersja dotyczy kartotek materiałowych.

2. Rozszerzono zakres informacji o towarze o dodatkowe pola:

Celem wprowadzenia w/w modyfikacji jest ujednolicenie nazewnictwa towarów. Nazwa towaru jest budowana w oparciu o pola: Wyróżnik, Materiał Grubość, Szerokość Długość i Długość profilu. W celu utworzenia nazwy towaru należy wypełnić wymagane pola i nacisnąć przycisk "Utwórz nazwę".

Słownik materiałów definiowany jest w "Systematyka > Słowniki > Rodzaje materiału"

Poprawione błędy:

1. Poprawiono błąd sumowania wartości dokumentu magazynowego. W przypadku gdy ilość pozycji na dokumencie była większa niż 255, to błędnie podawana była suma dokumentu wyświetlana na ekranie. Wydruk dokumentu był prawidłowy.

Wersja F.2.93 z 10.10.2010

Zmiany:

1. Rozszerzono import maszyn o możliwość odczytu maszyn z pliku "maszyny.csv". Poszczególne pola rekordu oddzielone są średnikami, a struktura rekordu jest następująca:

Kod - kod maszyny

Nazwa - nazwa maszyny

Uwagi - nazwa angielska maszyny

Uwagi 2 - dodatkowy opis

kod Mtnc - nr ewidencyjny maintenance

Grupa CC - grupa CC

Status - status rekordu (3-nowy, 5-zmiana, 8-do historii)

Wersja F.2.91 z 16.01.2010

Zmiany:

1. Rozszerzono wydruk "Obrotów dla zleceń" o kolumny zawierające daty ostatniego przychodu i rozchodu.

Wersja F.2.90 z 01.08.2009

Zmiany:

Rozszerzono program o obsługę kodów kreskowych i synchronizację listy maszyn z e-LogBook. Wprowadzono obsługę drukarki etykiet oraz czytników kodów działających w trybie off-line. Drukarka kodów kreskowych obsługiwana jest przez język ZPL II (Zebra Programming Language), natomiast obsługiwanym czytnikiem kodów jest terminal CPT 8300. W wyniku przeprowadzonych analiz i konsultacji przyjęto koncepcję, w której kod kreskowy przypisany jest do kartoteki materiałowej, a nie do stanu materiałowego. Zatem wszystkie dostawy dotyczące konkretnego produktu (w tym od różnych dostawców) mają ten sam kod kreskowy. Zastosowano kod kreskowy w formacie Code 39.

W związku z powyższym:

1. Na formularzu parametrów systemu (Systematyka > Parametry stystemu > Obsługa kodów kreskowych) dodano nowe pola:

W sekcji dotyczącej obsługi kodów kreskowych ustawiane są następujące parametry:

- Port LPT drukarki kodów - numer portu, pod który podłączona jest drukarka kodów. Ponieważ drukarka podłączana jest poprzez USB, numer tego portu jest numerem wirtualnym. Nie jest to numer fizycznego portu w komputerze. Można podać wartości od 0-4, przy czym 0 oznacza brak podłączenia drukarki. Ustawienie to ma niższy priorytet niż "Zasób sieciowy drukarki"

- Zasób sieciowy dla drukarki - wskazuje ścieżkę UNC do udostępnianej w sieci drukarki kodów. Ma to znaczenie w przypadku współdzielenia jednej drukarki przez kilku użytkowników. W przypadku wypełnienia tego pola, w czasie komunikacji z drukarką program ignoruje ustawienia zapisane w "Port LPT".

- Port COM czytnika kodów - numer portu, pod który podłączony jest czytnik kodów kreskowych. Ponieważ czytnik podłączony jest poprzez USB, numer tego portu jest numerem wirtualnym. Nie jest to numer fizycznego portu w komputerze. Można podać wartości od 0-99, przy czym 0 oznacza brak podłączenia czytnika.

- Polskie znaki w drukarce - w przypadku włączenia tej opcji generowanie etykiet będzie uwzględniać polskie litery, jednak warunkiem poprawnego wydrukowania tych etykiet jest wgranie do pamięci drukarki odpowiedniej czcionki. W przypadku braku tej czcionki, polskie litery nie będą drukowane.

- Polskie znaki w czytniku - w przypadku włączenia tej opcji generowanie słowników dla czytnika kodów kreskowych będzie uwzględniać polskie litery, jednak warunkiem ich prawidłowego wyświetlania na monitorze czytnika jest wgranie odpowiedniej czcionki do czytnika i przestawienie w nim strony kodowej. W przypadku braku tej czcionki, polskie litery nie będą prawidłowo wyświetlane.

2. Rozszerzono funkcjonalność listy towarów o możliwość drukowania etykiet z kodami kreskowymi.

Dodano możliwość zaznaczenia klawiszem spacji, pozycji dla których na nastąpić wydruk etykiet. W wyniku naciśnięcia spacji pojawia się pytanie o ilość etykiet do wydrukowania, przy czym zatwierdzenie formularza z zerową ilością oznacza wydruk jednej etykiety. Wydruk zaznaczonych etykiet odbywa się poprzez akcję "F11 Druk etykiet". W przypadku, gdy nie jest zaznaczona żadna pozycja na liście, wydruk etykiety będzie dotyczył aktualnie podświetlonej pozycji, przy czym wydrukowana zostanie jedna etykieta.

Dodatkowo w ostatniej kolumnie listy (K.K.) podawany jest opis kodu kreskowego.

3. Rozszerzono formularz pozycji dokumentu o pole dotyczące ilości etykiet do wydruku.

Podanie w polu "Etykiet" wartości większej od zera, oznacza, że po zapisie wprowadzanego dokumentu uruchomiony zostanie proces drukowania etykiet na drukarce etykiet. Dzięki temu, już podczas wprowadzania dokumentu (głównie PZ) można określić ilość potrzebnych etykiet.

4. Stworzono aplikację dla czytnika kodów przy użyciu generatora aplikacji, która pozwala na rejestrowanie w czytniku poszczególnych wydań towaru z magazynów. Do pracy aplikacja wykorzystuje dwa słowniki: słownik pozycji materiałowych oraz słownik zleceń (maszyn). Oba słowniki posiadają kody kreskowe, poprzez które następuje identyfikacja towaru i zlecenia. Dane zwracane przez czytnik zawierają informacje o kodzie, ilości wydanego towaru, numerze zlecenia, na które nastąpiło wydanie oraz czasie wykonania operacji.

5. Rozszerzono program o możliwość komunikacji z czytnikiem. Opcje związane z komunikacją dostępne są w menu Dokumenty > Czytnik kodów kreskowych.

Znaczenie poszczególnych opcji jest następujące:

- Pobranie danych z czytnika - pozwala na odczytanie wydań towarów zarejestrowanych w czytniku. Dane pobrane z czytnika zapisywane są w katalogu KK_Dane do pliku Dane.txt. Kolejne odczyty z czytnika dodają odczytane dane do istniejących już w pliku Dane.txt.

- Tworzenie dokumentów RW - na podstawie danych z odczytu z czytnika, zapisanych w pliku Dane.txt, następuje wygenerowanie dokumentów RW w magazynach, z których pochodzą wydane towary. Dodatkowo analizowane są stany magazynowe poszczególnych towarów, a na ich podstawie określana ilość i cena wydawanego towaru na poszczególnych pozycjach tworzonych dokumentów. Z przebiegu procedury sporządzany jest raport, na którym przedstawiane są ewentualne napotkane problemy. Raport zapisywany jest w katalogu KK_Dane pod nazwą "Raport_<data i czas odczytu>.txt", a nazwa pliku z odczytanymi danymi zostaje zmieniana na "Dane_<data i czas odczytu>.txt" Utworzone tą procedurą dokumenty NIE są księgowane, ta czynność zostaje po stronie operatora.

- Utwórz i wyślij słownik .... - opcje pozwalające na wgranie słowników na czytnik kodów. Słowniki są wykorzystywane podczas pracy z czytnikiem. Po zeskanowaniu kodu kreskowego, przeszukiwany jest słownik i w przypadku odnalezienia w nim pozycji odpowiadającej odczytanemu kodowi, pokazywany jest szczegółowy opis. Dla przykładu, po zeskanowaniu kodu z etykiety towaru, podawana jest nazwa towaru oraz jednostka miary, podobnie po zeskanowaniu kodu zlecenia (maszyny) podawany jest jego opis. Podczas wykonywania tych opcji należy postępować zgodnie z komunikatami na ekranie i na czytniku kodów.

- Słownik zleceń dla EXCELa - opcja pozwala na zapisanie zleceń wraz z ich kodami kreskowymi do pliku tekstowego. Plik ten można następnie wczytać do EXCELa i stworzyć katalog kodów kreskowych dla zleceń. Kod kreskowy zlecenia tworzony jest na podstawie kodu zlecenia i uzupełniany o sumę kontrolną. Dla kolumny z kodem kreskowym należy zastosować czcionkę kodu kreskowego pamiętając jednocześnie, że przed i za kodem kreskowym musi pozostać ok 0,5 cm wolnego miejsca, aby obramowanie tabeli nie wpływało na odczyt kodu, przy czym czcionka kodu kreskowego nie powinna być mniejsza niż 16 punktów. Ewentualna niezgodność znaków zastosowanych w kodzie zlecenia ze standardem Code 39 jest komunikowana podczas tworzenia tego słownika.

6. Wprowadzono mechanizm pozwalający na synchronizację listy maszyn pomiędzy programami EM_WIN i e-LogBook. Opcje odpowiedzialne za ten proces dostępne są w menu Produkcja > Opcje techniczne:

Synchronizacja maszyn pozwala na ujednolicenie listy maszyn w obu programach. Mechanizm wykonania synchronizacji polega na wyeksportowaniu maszyn z jednego programu i zaimportowaniu ich w drugim. Podczas eksportu tworzony jest plik "Maszyny.dat" w głównym katalogu programu. W celu synchronizacji, plik ten należy przegrać do katalogu głównego drugiego programu i z poziomu drugiego programu wykonać "Import i aktualizację maszyn". Z procesu synchronizacji generowany jest raport informujący o wprowadzonych zmianach.

Wersja F.2.83 z 05.06.2009

Zmiany:

1. Wprowadzono obsługę grup zleceń (maszyn) jako elementu pozwalającego na dodatkowe filtrowanie zestawień obrotu dla zleceń.

W tym celu:

- w menu Systematyka > Słowniki dodano opcję pozwalającą definiować słownik grup zleceń:

- na formularzu zlecenia dodano możliwość przypisania zlecenia do grupy zleceń:

- na formularzu parametrów wydruku obrotów dla zleceń dodano możliwość ustawienia filtra na grupy zleceń.

- rozszerzono wydruk obrotu dla zleceń o stosowanie filtra na grupę zleceń, informację o grupie zleceń oraz podsumowanie obrotów w poszczególnych grupach zleceń.

Wersja F.2.76 z 01.09.2008

Zmiany:

1. W menu "Systematyka" dodano opcję "Parametry systemu". W wyniku jej wybrania pojawia się formularza pozwalający określić pewne parametry związane z pracą programu:

W górnej części formularza znajdują się opcje pozwalające określić mechanizm automatycznej archiwizacji danych. Idea tego mechanizmu jest następująca:

- program uruchamiany jest na serwerze, dla operatora mającego w swoich parametrach ustawioną opcję "Serwer archiwizacji" (nowa opcja)

- ustawiamy godzinę wykonywania archiwizacji np: 22:00

- ustawiamy szacowany czas zakończenia archiwizacji np: 22:15;

- ustawiamy "Start powiadamiania" na 21:45

- opcjonalnie można określić dodatkowy katalog, do którego będzie kopiowane sporządzone archiwum np: F:\EM_Archiw (chodzi o możliwość kopiowania tego archiwum na fizycznie inny komputer w celu poprawienia bezpieczeństwa danych)

Po ustawieniu w/w parametrów jak w przykładzie, od godz 21:45 wszystkie podłączone do sieci stanowiska pracujące na programie zaczną być powiadamiane o rozpoczęciu archiwizacji za ilość minut wynikającą z różnicy pomiędzy czasem aktualnym, a godz 22:00. O godz 22:00 nastąpi automatyczne zamknięcie programu na stacjach roboczych oraz ustawienie flagi rozpoczęcia archiwizacji. W tym czasie nikt nie będzie mógł zalogować się do programu. Po zakończeniu archiwizacji flaga archiwizacji zostanie zdjęta, tym samym można ponownie zalogować się do programu. Archiwizacja wykonywana jest przez komputer, na którym zalogowany jest operator mający ustawioną opcję "Serwer archiwizacji", przy czym takie logowanie powinno odbywać się na serwerze.

W środkowej części okna mamy "Inne parametry". Obecnie jest tam opcja decydująca o sposobie pobierania danych o stawce roboczo-godziny do kalkulacji czasu pracy, aktualizacji cen oraz wypełniania karty pracy pracownika. W przypadku gdy opcja "Roboczo-Godzina w/g działów" nie jest zaznaczona, to stawka roboczo-godziny pobierana jest ze stanowiska pracy, w przeciwnym układzie ze stawki określonej dla działu.

2. Wprowadzono możliwość wydrukowania stanu magazynu na dowolny dzień (Wydruki > Ewidencja stanów magazynowych > 6. Stan magazynu na dzień). Na pojawiającym się formularzu można określić dzień, na który chcemy uzyskać stany magazynowe. Raport powstaje poprzez analizę zaksięgowanych dokumentów magazynowych.

3. Wprowadzono kilka usprawnień związanych z wprowadzaniem dokumentów magazynowych.

W przypadku dokumentu MM- dodano możliwość wskazania magazynu docelowego. Podczas księgowania dokumentu w magazynie źródłowym zostaje on również wprowadzony i zaksięgowany w magazynie docelowym.

Nad listą pozycji magazynowych dodano informację o nazwie danej pozycji (na liście jest podany kod)

Dla dokumentów przychodowych aktywny jest klawisz F2 Lista, pozwalający na wypełnianie dokumentu przychodowego w oparciu o listę materiałów. Po jego naciśnięciu pojawia się pytanie o określenie zlecenia, którym będą cechowane wybrane pozycje materiałowe. W przypadku odpowiedzi twierdzącej pojawi się lista zleceń, z której należy wybrać zlecenie. Następnie pojawi się pytanie o sposób sortowanie listy materiałów (w/g kodów lub w/g nazw) oraz sama lista materiałów.

Zaznaczenie pozycji odbywa się klawiszem spacji, którego naciśnięcie skutkuje pojawieniem się formularza z pytaniem o ilość i cenę wprowadzanego materiału. Możliwe jest także uzupełnianie tej listy o nowe materiały (w zależności od uprawnień). Po zatwierdzeniu listy klawiszem "WYBIERZ" lub "ENTER" zaznaczone pozycje przenoszone są do dokumentu magazynowego.

Dodano możliwość zaznaczania pozycji dokumentu oraz wykonania kasowania na tych pozycjach:

Zaznaczanie pozycji odbywa się klawiszem "Spacji". Zaznaczone pozycje oznaczone są znakiem "v" w kolumnie statusu "S". Ponadto podawana jest ilość zaznaczonych pozycji na dokumencie w górnej części listy. Jeżeli są zaznaczone pozycje na liście, to w wyniku wybrania opcji "F8 Usuń", pojawia się pytanie czy kasowanie ma obejmować zaznaczone pozycje (wszystkie). Odpowiedź twierdząca ocechuje zaznaczone pozycje jako skasowane, natomiast odpowiedź negatywna ograniczy kasowanie tylko do aktualnie podświetlonej pozycji, tak jak dotychczas

Poprawione błędy:

1. Poprawiono wyświetlanie listy dokumentów magazynowych po skasowaniu dokumentu - pojawiały się dokumenty z innego magazynu i miesiąca.


New Topic

New Topic